summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-03-24 18:31:27 +0000
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-03-24 19:59:43 +0000
commit25022bfd3a683527e7dd1644c6edc44eef03da0e (patch)
tree82d5a7a2c5291fec703b37c51ec74f67dc01b295
parent57e12aad6dfc2d12567164144dd15161e66f32d5 (diff)
downloadpatches-25022bfd3a683527e7dd1644c6edc44eef03da0e.tar
patches-25022bfd3a683527e7dd1644c6edc44eef03da0e.tar.gz
gnu: Add perl-mail-sendmail.
* gnu/packages/perl.scm (perl-mail-sendmail): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0d4dcd6fe0..77fbc92710 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Stephen J. Scheck <sscheck@cpan.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5281,6 +5282,28 @@ Build a Mail::Internet object, and then send it out using Mail::Mailer.
\"Smart functions\" you should not depend on.
@end table")
(license perl-license)))
+(define-public perl-mail-sendmail
+ (package
+ (name "perl-mail-sendmail")
+ (version "0.80")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/N/NE/NEILB/Mail-Sendmail-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1r38qbkj7jwj8cqy1rnqzkk81psxi08b1aiq392817f3bk5ri2jv"))))
+ (build-system perl-build-system)
+ (arguments `(#:tests? #f)) ;socket not available during build
+ (home-page "https://metacpan.org/release/Mail-Sendmail")
+ (synopsis "Simple platform independent mailer")
+ (description "Mail::Sendmail is a pure perl module that provides a
+simple means to send email from a perl script. The module only
+requires Perl5 and a network connection.")
+ (license perl-license)))
(define-public perl-math-bezier
(package