summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-03-21 12:26:21 +0100
committerLeo Famulari <leo@famulari.name>2020-03-24 17:10:20 -0400
commit01e30442007a5d2b0f8c443896f7d6dc850b140f (patch)
treeb9d780b89c04018c05b7ad54e27cf65109142bff
parent6dcbd20afa775ba28b7e7986daa6fc4c5981fe0c (diff)
downloadpatches-01e30442007a5d2b0f8c443896f7d6dc850b140f.tar
patches-01e30442007a5d2b0f8c443896f7d6dc850b140f.tar.gz
gnu: python-sortedcontainers: Add missing propagated-inputs.
* gnu/packages/python-xyz.scm (python-sortedcontainers): [propagated-inputs] Add python-appdirs, python-distlib, python-filelock, python-importlib-metadata and python-six. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44a893a9d6..ea2b14a6ec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16748,6 +16748,12 @@ that is accessible to other projects developed in Cython.")
(build-system python-build-system)
(native-inputs
`(("python-tox" ,python-tox)))
+ (propagated-inputs
+ `(("python-appdirs" ,python-appdirs)
+ ("python-distlib" ,python-distlib)
+ ("python-filelock" ,python-filelock)
+ ("python-importlib-metadata" ,python-importlib-metadata) ;; python < 3.8
+ ("python-six" ,python-six)))
(home-page "http://www.grantjenks.com/docs/sortedcontainers/")
(synopsis "Sorted List, Sorted Dict, Sorted Set")
(description