summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 22:07:38 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 22:07:38 +0100
commit6145b604629c071fba8b55b7e0e3a45ed68fa3cc (patch)
tree7000cd27f3c79f4005c084d6f9a7d1cbedf6e2a7
parentb7f3ea9532c0bf764228b3b7ecbd66d579a2517f (diff)
downloadpatches-6145b604629c071fba8b55b7e0e3a45ed68fa3cc.tar
patches-6145b604629c071fba8b55b7e0e3a45ed68fa3cc.tar.gz
gnu: python-clint: Fix tests.
* gnu/packages/python.scm (python-clint, python2-clint)[native-inputs]: Add python-pytest. [arguments]: Replace 'check' phase with custom command.
-rw-r--r--gnu/packages/python.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d6ea07de34..17469036a3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8125,6 +8125,14 @@ Blog, News or Announcements section to a Sphinx website.")
(base32
"1an5lkkqk1zha47198p42ji3m94xmzx1a03dn7866m87n4r4q8h5"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "py.test" "-v")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-args" ,python-args)))
(home-page "https://github.com/kennethreitz/clint")