summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-15 18:22:48 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-09-17 11:05:17 +1000
commit5eebe8dcf746fb6e53a2e9d9d8bed7177de62806 (patch)
tree8db9894e10f3e0c7b7086e8457bb7e9b00029117
parentf76d56d2868e4339915c42d3d9b93c1cb38e7e92 (diff)
downloadpatches-5eebe8dcf746fb6e53a2e9d9d8bed7177de62806.tar
patches-5eebe8dcf746fb6e53a2e9d9d8bed7177de62806.tar.gz
gnu: python-cleo: Update to 0.6.1.
* gnu/packages/databases.scm (python-cleo): Update to 0.6.1. [native-inputs]: Add python-pytest-mock. [propagated-inputs]: Add python-backpack, python-pastel. Remove python-psutil.
-rw-r--r--gnu/packages/python.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d7d8a540eb..d04d7cb1a8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages graphviz)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
@@ -11983,20 +11984,22 @@ Wikipedia code samples at
(define-public python-cleo
(package
(name "python-cleo")
- (version "0.4.1")
+ (version "0.6.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "cleo" version))
(sha256
(base32
- "1k2dcl6mqpn5bljyl6w42rqyd9mb3y9kh2mg7m2x3kfjwvg0rpva"))))
+ "0q1cf0szr0d54am4pypzwdnm74zpladdsinad94c2fz5i06fdpf7"))))
(build-system python-build-system)
(native-inputs
`(;; For testing
("python-mock" ,python-mock)
+ ("python-pytest-mock" ,python-pytest-mock)
("python-pytest" ,python-pytest)))
(propagated-inputs
- `(("python-psutil" ,python-psutil)
+ `(("python-backpack" ,python-backpack)
+ ("python-pastel" ,python-pastel)
("python-pylev" ,python-pylev)))
(home-page "https://github.com/sdispater/cleo")
(synopsis "Command-line arguments library for Python")