summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-03-21 19:58:43 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-03-24 11:42:40 +0100
commitefcb05083f869b1d429fbad2f7bb008799ae33be (patch)
treeb6e310e34526bbbdcdd37abe11407c3107b6d193
parentb0d1da986b262685d092bb192feb49ab9db1dd8a (diff)
downloadpatches-efcb05083f869b1d429fbad2f7bb008799ae33be.tar
patches-efcb05083f869b1d429fbad2f7bb008799ae33be.tar.gz
gnu: Add python-owslib.
* gnu/packages/python-xyz.scm (python-owslib): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5336df0ab7..4c71546fab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -59,7 +59,7 @@
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
-;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
@@ -18460,3 +18460,24 @@ utility and generating summarized code coverage results. It is inspired
by the Python coverage.py package, which provides a similar utility for
Python.")
(license license:bsd-3)))
+
+(define-public python-owslib
+ (package
+ (name "python-owslib")
+ (version "0.19.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "OWSLib" version))
+ (sha256
+ (base32 "0v8vg0naa9rywvd31cpq65ljbdclpsrx09788v4xj7lg10np8nk0"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; TODO: package dependencies required for tests.
+ (synopsis "Interface for Open Geospatial Consortium web service")
+ (description
+ "OWSLib is a Python package for client programming with Open Geospatial
+Consortium (OGC) web service (hence OWS) interface standards, and their related
+content models.")
+ (home-page "https://geopython.github.io/OWSLib/")
+ (license license:bsd-3)))