summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-15 23:14:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:53:56 +0200
commitcb380998395b4b6f64dfaed6de5ced8c8c0682aa (patch)
treedf8c24eb0e10b5a8b7e80360f67669775e652ca4
parent44b9e8fd8f10c4f028607501f01a2f70e3c5d780 (diff)
downloadpatches-cb380998395b4b6f64dfaed6de5ced8c8c0682aa.tar
patches-cb380998395b4b6f64dfaed6de5ced8c8c0682aa.tar.gz
gnu: Add go-github-com-klauspost-cpuid.
* gnu/packages/golang.scm (go-github-com-klauspost-cpuid): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9a0b097201..4a3b50e588 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3572,3 +3572,28 @@ characters with their ASCII approximations.")
(synopsis "Go library that pluralizes and singularizes English nouns")
(description "Go library that pluralizes and singularizes English nouns.")
(license license:bsd-2))))
+
+(define-public go-github-com-klauspost-cpuid
+ (package
+ (name "go-github-com-klauspost-cpuid")
+ (version "1.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/cpuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s510210wdj5dkamii1qrk7v87k4qpdcrrjzflp5ha9iscw6b06l"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/klauspost/cpuid"))
+ (home-page "https://github.com/klauspost/cpuid")
+ (synopsis "CPU feature identification for Go")
+ (description "@code{cpuid} provides information about the CPU running the
+current program. CPU features are detected on startup, and kept for fast access
+through the life of the application. Currently x86 / x64 (AMD64) is supported,
+and no external C (cgo) code is used, which should make the library very eas
+to use.")
+ (license license:expat)))