summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-23 19:40:47 -0400
committerLeo Famulari <leo@famulari.name>2020-03-23 21:17:46 -0400
commitaae5f89db07354a96149a43e980fca2af6fce628 (patch)
treeada836ed87efa1909f4bd28d7ba7ecc5119cc4fc
parentacd595c2375c8a9134a376eb92dec694c8fada3c (diff)
downloadpatches-aae5f89db07354a96149a43e980fca2af6fce628.tar
patches-aae5f89db07354a96149a43e980fca2af6fce628.tar.gz
gnu: Git: Update to 2.26.0.
* gnu/packages/version-control.scm (git): Update to 2.26.0. [arguments]: Adjust the 'install-credential-netrc' phase to upstream changes.
-rw-r--r--gnu/packages/version-control.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5049d45f1c..4da8e33e04 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -150,14 +150,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git-source' input to cgit
;; needs to be updated as well.
- (version "2.25.2")
+ (version "2.26.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "08vivrv3my8nlp40pwsf7mcc5k7dwyh34hadjszx7qj8w01p34wv"))))
+ "1mlmwibfgcv42c28fxmbd3iim8fc06r17dljd8vdgq550z5hvkly"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -170,7 +170,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "06nlw6vaqvavkr4nia9qvanqbhaig4hbg9r5f0i9lbvw1hmykfvq"))))
+ "09ilv5gg7167mwc0qqw2fz3lmdm360crnxc0xzkqn53wnsh4cziq"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)
@@ -338,8 +338,10 @@ as well as the classic centralized workflow.")
(add-after 'install 'install-credential-netrc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((netrc (assoc-ref outputs "credential-netrc")))
- (install-file "contrib/credential/netrc/git-credential-netrc"
+ (install-file "contrib/credential/netrc/git-credential-netrc.perl"
(string-append netrc "/bin"))
+ (rename-file (string-append netrc "/bin/git-credential-netrc.perl")
+ (string-append netrc "/bin/git-credential-netrc"))
;; Previously, Git.pm was automatically found by netrc.
;; Perl 5.26 changed how it locates modules so that @INC no
;; longer includes the current working directory (the Perl