summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-03-23 18:15:02 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-23 19:02:46 +0100
commit7884fc434f5d4a11b1dd566553b83fae09c44fad (patch)
tree155e68f312ac0ba9f98d9a753ef8f676b33c0f2f
parent4233e74b39635d5ef4dde204ecc26dcc894d9467 (diff)
downloadpatches-7884fc434f5d4a11b1dd566553b83fae09c44fad.tar
patches-7884fc434f5d4a11b1dd566553b83fae09c44fad.tar.gz
gnu: youtube-dl: Add zsh completion.
* gnu/packages/video.scm (youtube-dl)[arguments]: Add phase install-completion. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/video.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3b64c435b7..cb575a7375 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1673,6 +1673,15 @@ To load this plugin, specify the following option when starting mpv:
(("'share/")
(string-append "'" prefix "/share/")))
#t)))
+ (add-after 'install 'install-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (zsh (string-append out
+ "/share/zsh/site-functions")))
+ (mkdir-p zsh)
+ (copy-file "youtube-dl.zsh"
+ (string-append zsh "/_youtube-dl"))
+ #t)))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))