summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-03-23 18:14:45 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-03-24 09:31:43 +0100
commit47a2306415cf19270cb398590be3d95a92a0e73b (patch)
treea553cd61c7f38ee1675caa9a50b8265867271e17
parent0f96fd645402f18bfe0ebeb4159e2daea8cad154 (diff)
downloadpatches-47a2306415cf19270cb398590be3d95a92a0e73b.tar
patches-47a2306415cf19270cb398590be3d95a92a0e73b.tar.gz
gnu: sbcl: Increase maximum heap size to 2Gb.
* gnu/packages/lisp.scm (sbcl)[arguments]: Add the "--dynamic-space-size=2Gb" option in the build phase.
-rw-r--r--gnu/packages/lisp.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2af0d78da3..a65eb19e0c 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -494,6 +494,7 @@ an interpreter, a compiler, a debugger, and much more.")
`("clisp")))
(string-append "--prefix="
(assoc-ref outputs "out"))
+ "--dynamic-space-size=2Gb"
"--with-sb-core-compression"
"--with-sb-xref-for-internals")))
(replace 'install