summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-03-23 18:15:01 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-23 19:02:44 +0100
commit4233e74b39635d5ef4dde204ecc26dcc894d9467 (patch)
treed8ac136ccf6e9d262fc9681b7448062453db7f2c
parent1a5443e86b99ce39508f38bf211970f3ae4ada7f (diff)
downloadpatches-4233e74b39635d5ef4dde204ecc26dcc894d9467.tar
patches-4233e74b39635d5ef4dde204ecc26dcc894d9467.tar.gz
gnu: youtube-dl: Add 'ffmpeg' as input.
* gnu/packages/video.scm (youtube-dl)[arguments]: Add phase wrap-executable. [inputs]: Add ffmpeg. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/video.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 38e9d36307..3b64c435b7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2019 Riku Viitanen <riku.viitanen@protonmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1671,7 +1672,17 @@ To load this plugin, specify the following option when starting mpv:
(string-append "'" prefix "/etc/"))
(("'share/")
(string-append "'" prefix "/share/")))
- #t))))))
+ #t)))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (ffmpeg (assoc-ref inputs "ffmpeg")))
+ (wrap-program (string-append out "/bin/youtube-dl")
+ `("PATH" ":" prefix
+ ,(list (string-append ffmpeg "/bin")))))
+ #t)))))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)))
(synopsis "Download videos from YouTube.com and other sites")
(description
"Youtube-dl is a small command-line program to download videos from