summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-15 23:13:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:12:49 +0200
commit40c86b39c3a9046e3371c0d4f2e530d7c6411771 (patch)
tree9fbb2f538ea19f1c57e21e3a1b94b86cc4343246
parentae863ccd63fedb734138d4bbc28fb51de26ac290 (diff)
downloadpatches-40c86b39c3a9046e3371c0d4f2e530d7c6411771.tar
patches-40c86b39c3a9046e3371c0d4f2e530d7c6411771.tar.gz
gnu: Add go-github-com-fogleman-gg.
* gnu/packages/golang.scm (go-github-com-fogleman-gg): New variable.
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5ab4bd52a5..52e8d7d52c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3524,3 +3524,27 @@ characters with their ASCII approximations.")
(description "The Freetype font rasterizer in the Go programming language.")
(license (list license:freetype
license:gpl2+)))))
+
+(define-public go-github-com-fogleman-gg
+ (package
+ (name "go-github-com-fogleman-gg")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fogleman/gg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nkldjghbqnzj2djfaxhiv35kk341xhcrj9m2dwq65v684iqkk8n"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ; Issue with test flags.
+ #:import-path "github.com/fogleman/gg"))
+ (propagated-inputs
+ `(("go-github-com-golang-freetype" ,go-github-com-golang-freetype)))
+ (home-page "https://github.com/fogleman/gg")
+ (synopsis "2D rendering in Go")
+ (description "@code{gg} is a library for rendering 2D graphics in pure Go.")
+ (license license:expat)))