summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-17 08:59:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:58:28 +0200
commit9a684b4078ef4bc05b3fd18ae5ca8235db66c910 (patch)
tree23aad79e420e3143d8e2a2e6eac8ca4083ef79c6
parent10d3fbf051da1af4d45e269394433ad072b1f6c7 (diff)
downloadpatches-9a684b4078ef4bc05b3fd18ae5ca8235db66c910.tar
patches-9a684b4078ef4bc05b3fd18ae5ca8235db66c910.tar.gz
gnu: Add python-keyrings.alt.
* gnu/packages/python-crypto.scm (python-keyring.alt): New variable.
-rw-r--r--gnu/packages/python-crypto.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 1286693fc2..6e85c0eea2 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -377,6 +377,45 @@ password storage.")
(propagated-inputs
`(("python2-pycrypto" ,python2-pycrypto))))))
+(define-public python-keyrings.alt
+ (package
+ (name "python-keyrings.alt")
+ (version "3.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "keyrings.alt" version))
+ (sha256
+ (base32
+ "0gdjdqpq2hf770p6iwi891mil0vbsdhvy88x0v8b2w4y4b28lcli"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file "keyrings/alt/_win_crypto.py")
+ ;; Rely on python-keyring>20:
+ ;; https://github.com/jaraco/keyrings.alt/issues/33
+ (substitute* '("keyrings/alt/tests/test_Gnome.py"
+ "keyrings/alt/tests/test_Google.py"
+ "keyrings/alt/tests/test_Windows.py"
+ "keyrings/alt/tests/test_file.py"
+ "keyrings/alt/tests/test_pyfs.py")
+ (("keyring.tests.test_backend") "keyring.testing.backend")
+ (("keyring.tests.util") "keyring.testing.util"))
+ #t))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-keyring" ,python-keyring)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/jaraco/keyrings.alt")
+ (synopsis "Alternate keyring implementations")
+ (description "Keyrings in this package may have security risks or other
+implications. These backends were extracted from the main keyring project to
+make them available for those who wish to employ them, but are discouraged for
+general production use. Include this module and use its backends at your own
+risk.")
+ (license license:expat)))
+
(define-public python-certifi
(package
(name "python-certifi")