summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-03-21 19:45:14 +0000
committerLudovic Courtès <ludo@gnu.org>2020-03-23 10:48:18 +0100
commit591faabd8c93bfb6879910d8a424f0db835066c2 (patch)
tree92fbd93c55e558a3d43926fafad8d63625cfdf81
parent670da39888170d8f6acb9d0f2cf724b02c9f7ccb (diff)
downloadpatches-591faabd8c93bfb6879910d8a424f0db835066c2.tar
patches-591faabd8c93bfb6879910d8a424f0db835066c2.tar.gz
gnu: Add python-gcovr.
* gnu/packages/python-xyz.scm (python-gcovr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 65bc6df4aa..5336df0ab7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -70,6 +70,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18435,3 +18436,27 @@ sequences.")
prevent debuggers and other applications from inspecting the memory within
your process.")
(license license:expat)))
+
+(define-public python-gcovr
+ (package
+ (name "python-gcovr")
+ (version "4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gcovr" version))
+ (sha256
+ (base32
+ "0gyady7x3v3l9fm1zan0idaggqqcm31y7g5vxk7h05p5h7f39bjs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)
+ ("python-jinja2" ,python-jinja2)))
+ (home-page "https://gcovr.com/")
+ (synopsis "Utility for generating code coverage results")
+ (description
+ "Gcovr provides a utility for managing the use of the GNU gcov
+utility and generating summarized code coverage results. It is inspired
+by the Python coverage.py package, which provides a similar utility for
+Python.")
+ (license license:bsd-3)))