summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-15 23:13:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:12:50 +0200
commit44b9e8fd8f10c4f028607501f01a2f70e3c5d780 (patch)
tree88119489cbae021188c2c6df4d6c50fee4bd45f4
parent40c86b39c3a9046e3371c0d4f2e530d7c6411771 (diff)
downloadpatches-44b9e8fd8f10c4f028607501f01a2f70e3c5d780.tar
patches-44b9e8fd8f10c4f028607501f01a2f70e3c5d780.tar.gz
gnu: Add go-github-com-gedex-inflector.
* gnu/packages/golang.scm (go-github-com-gedex-inflector): New variable.
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 52e8d7d52c..9a0b097201 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3548,3 +3548,27 @@ characters with their ASCII approximations.")
(synopsis "2D rendering in Go")
(description "@code{gg} is a library for rendering 2D graphics in pure Go.")
(license license:expat)))
+
+(define-public go-github-com-gedex-inflector
+ (let ((commit "16278e9db8130ac7ec405dc174cfb94344f16325")
+ (revision "1"))
+ (package
+ (name "go-github-com-gedex-inflector")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gedex/inflector")
+ (commit commit)))
+ (file-name (string-append "go-github-com-gedex-inflector-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "05hjqw1m71vww4914d9h6nqa9jw3lgjzwsy7qaffl02s2lh1amks"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gedex/inflector"))
+ (home-page "https://github.com/gedex/inflector")
+ (synopsis "Go library that pluralizes and singularizes English nouns")
+ (description "Go library that pluralizes and singularizes English nouns.")
+ (license license:bsd-2))))