summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpinoaffe@airmail.cc <pinoaffe@airmail.cc>2020-03-22 10:47:48 +0000
committerDanny Milosavljevic <dannym@scratchpost.org>2020-03-22 15:59:35 +0100
commit363989e6689068daeca81b442358b183b7d983d1 (patch)
tree67a38b0035d2e09bfd471238b290cde33b175167
parent179be4bbe488d6c18d482da69b4997f7682d5a58 (diff)
downloadpatches-363989e6689068daeca81b442358b183b7d983d1.tar
patches-363989e6689068daeca81b442358b183b7d983d1.tar.gz
gnu: Add nextpnr-ice40.
* gnu/packages/fpga.scm (nextpnr-ice40): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/fpga.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 5cfc9a96f6..8f34ef8282 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -44,6 +44,9 @@
#:use-module (gnu packages gperf)
#:use-module (gnu packages gawk)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages libftdi))
(define-public abc
@@ -256,6 +259,41 @@ For synthesis, the compiler generates netlists in the desired format.")
Includes the actual FTDI connector.")
(license license:isc))))
+(define-public nextpnr-ice40
+ (let [(commit "c192ba261d77ad7f0a744fb90b01e4a5b63938c4")
+ (revision "0")]
+ (package
+ (name "nextpnr-ice40")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://github.com/YosysHQ/nextpnr")
+ (commit commit)))
+ (sha256
+ (base32
+ "0g2ar1z89b31qw5vgqj2rrcv9rzncs94184dgcsrz19p866654mf"))))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("boost" ,boost-with-python3)
+ ("yosys" ,yosys)
+ ("eigen" ,eigen)
+ ("python" ,python)
+ ("icestorm" ,icestorm)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags `("-DARCH=ice40"
+ ,(string-append "-DICEBOX_ROOT="
+ (assoc-ref %build-inputs "icestorm")
+ "/share/icebox"))
+ #:tests? #f))
+ (synopsis "Place-and-Route tool for FPGAs")
+ (description "nextpnr aims to be a vendor neutral, timing driven,
+FOSS FPGA place and route tool. ")
+ (home-page "https://github.com/YosysHQ/nextpnr")
+ (license license:expat))))
+
(define-public arachne-pnr
(let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")
(revision "2"))