summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-03-21 18:44:13 +0000
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-23 15:39:00 +0100
commit2f4faccc6fcdddbfad5a283c716fce640ca48916 (patch)
treee4b91f798ff0da86a0e9f3391238a20241345aff
parent7ff639510096ff762b9cced5fba6db254a961af9 (diff)
downloadpatches-2f4faccc6fcdddbfad5a283c716fce640ca48916.tar
patches-2f4faccc6fcdddbfad5a283c716fce640ca48916.tar.gz
gnu: Add ztoolkit.
* gnu/packages/audio.scm (ztoolkit): New variable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
-rw-r--r--gnu/packages/audio.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bad6f4a18d..b9cb3a4c29 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4118,3 +4118,33 @@ about the given LV2 plugin, provided that the plugin and its UI(s) match up
with the provided metadata and adhere to well-known best practices.")
(home-page "https://github.com/x42/lv2toweb")
(license (list license:isc license:gpl2))))
+
+(define-public ztoolkit
+ (package
+ (name "ztoolkit")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/ztoolkit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "GUI toolkit for LV2 plugins")
+ (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
+inspired by GTK. It handles events and low level drawing on behalf of
+the user and provides a high-level API for managing the UI and custom
+widgets. ZToolkit is written in C and was created to be used for building
+audio plugin UIs, where the dependencies often need to be kept to a
+minimum.")
+ (home-page "https://git.zrythm.org/cgit/ztoolkit/")
+ (license license:agpl3+)))