summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-17 09:03:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:58:29 +0200
commit0a124c4615bd150c36dd90c2595942b79dabef6e (patch)
tree1825f218b60daaf1d3f8447e37fd2de3d758b924
parent0831063778ee98d8aa9bdfaeeb7cd1673ef2a580 (diff)
downloadpatches-0a124c4615bd150c36dd90c2595942b79dabef6e.tar
patches-0a124c4615bd150c36dd90c2595942b79dabef6e.tar.gz
gnu: Add python-privy.
* gnu/packages/python-crypto.scm (python-privy): New variable.
-rw-r--r--gnu/packages/python-crypto.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index f1604212e7..0601799c2b 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1347,3 +1347,38 @@ I/O-free core, and integration modules for different event loops.")
both a configurable runtime as well as memory consumption. This means that you
can decide how long it takes to hash a password and how much memory is required.")
(license license:expat)))
+
+(define-public python-privy
+ (package
+ (name "python-privy")
+ (version "6.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; Releases are untagged
+ (url "https://github.com/ofek/privy")
+ (commit "2838db3df239797c71bddacc48a4c49a83f35747")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m32dh5fqc8cy7jyf1z5fs6zvmdkbq5fi98hr609gbl7s0l0y0i9"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "-m" "pytest"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-argon2-cffi" ,python-argon2-cffi)
+ ("python-cryptography" ,python-cryptography)))
+ (home-page "https://www.dropbox.com/developers")
+ (synopsis "Library to password-protect your data")
+ (description
+ "Privy is a small and fast utility for password-protecting secret
+data such as API keys, cryptocurrency wallets, or seeds for digital
+signatures.")
+ (license (list license:expat license:asl2.0)))) ; dual licensed