summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-03-20 19:34:51 +0000
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 20:17:21 +0100
commite7c7912573111d5e86f3e3012a6edab948f7b302 (patch)
treeeadcdd22db48dcbfeccd7e9dc3aa2017747ee4c5
parent0cec5c4eb1b4ac9a3fbe3f11cffff92e01ff4c58 (diff)
downloadpatches-e7c7912573111d5e86f3e3012a6edab948f7b302.tar
patches-e7c7912573111d5e86f3e3012a6edab948f7b302.tar.gz
gnu: Add gnome-shell-extension-topicons-redux.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-topicons-redux): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/gnome-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index aeeced42bd..d9d757e614 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -146,6 +147,47 @@ GNOME Shell.")
(home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
(license license:gpl2+)))
+(define-public gnome-shell-extension-topicons-redux
+ (package
+ (name "gnome-shell-extension-topicons-redux")
+ (version "6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/pop-planet/TopIcons-Redux.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dli9xb545n3xlj6q4wl0y5gzkm903zs47p8fiq71pdvbr6v38rj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")))
+ (arguments
+ `(#:tests? #f ;no test defined in the project
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make"
+ "install"
+ (string-append
+ "INSTALL_PATH="
+ out
+ "/share/gnome-shell/extensions"))))))))
+ (home-page "https://gitlab.com/pop-planet/TopIcons-Redux")
+ (synopsis "Display legacy tray icons in the GNOME Shell top panel")
+ (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the backround.")
+ (license license:gpl2+)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")