summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-21 20:41:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-21 20:42:52 +0100
commitdde3f551568bb7157b61eb8415b0fef94bfe8eb4 (patch)
tree526479106a6ba6ac260468babba92bd1ab0fb707
parentb1ebda07cb475c18d7812cf846141ac50a8fa5f1 (diff)
downloadpatches-dde3f551568bb7157b61eb8415b0fef94bfe8eb4.tar
patches-dde3f551568bb7157b61eb8415b0fef94bfe8eb4.tar.gz
gnu: gpgme: Fix build.
Reported by joshuaBPMan on #guix. * gnu/packages/gnupg.scm (gpgme)[arguments]: Add ‘disable-failing-test’ phase.
-rw-r--r--gnu/packages/gnupg.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c15cabc032..856c01a6d8 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -400,6 +400,15 @@ libskba (working with X.509 certificates and CMS data).")
(sha256
(base32 "0imyjfryvvjdbai454p70zcr95m94j9xnzywrlilqdw2fqi0pqy4"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ ;; XXX gnupg@2.2.20 breaks the expected JSON response for this test.
+ (lambda _
+ (substitute* "tests/json/t-json.c"
+ (("\"t-keylist-secret\", ") ""))
+ #t)))))
(native-inputs
`(("gnupg" ,gnupg)))
(propagated-inputs