summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-21 21:24:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 21:38:08 +0100
commit18401bdf69b2540b13db86aed199d1ebc585a844 (patch)
tree5100d9e3ba016df4bff95b557830e069cab494a1
parentdde3f551568bb7157b61eb8415b0fef94bfe8eb4 (diff)
downloadpatches-18401bdf69b2540b13db86aed199d1ebc585a844.tar
patches-18401bdf69b2540b13db86aed199d1ebc585a844.tar.gz
Revert "gnu: Remove qemu-minimal@2.10."
This package was still in use by american-fuzzy-lop. This reverts commit 559f37328851fc1ae1d90f27fab7beff3d804421.
-rw-r--r--gnu/packages/virtualization.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index b7e2c415fe..03f0ceaeee 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -284,6 +284,34 @@ server and embedded PowerPC, and S390 guests.")
'("libusb" "mesa" "sdl2" "spice" "virglrenderer" "gtk+"
"usbredir" "libdrm" "libepoxy" "pulseaudio" "vde2")))))
+;; The GRUB test suite fails with later versions of Qemu, so we
+;; keep it at 2.10 for now. See
+;; <https://lists.gnu.org/archive/html/bug-grub/2018-02/msg00004.html>.
+;; This package is hidden since we do not backport updates to it.
+(define-public qemu-minimal-2.10
+ (hidden-package
+ (package
+ (inherit qemu-minimal)
+ (version "2.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.qemu.org/qemu-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "17w21spvaxaidi2am5lpsln8yjpyp2zi3s3gc6nsxj5arlgamzgw"))
+ (patches
+ (search-patches "qemu-glibc-2.27.patch"))))
+ ;; qemu-minimal-2.10 needs Python 2. Remove below once no longer necessary.
+ (native-inputs `(("python-2" ,python-2)
+ ,@(fold alist-delete (package-native-inputs qemu-minimal)
+ '("python-wrapper" "python-sphinx"))))
+ (inputs
+ (fold alist-delete (package-inputs qemu-minimal)
+ ;; Disable seccomp support, because it's not required for the GRUB
+ ;; test suite, and because it fails with libseccomp 2.4.2 and later.
+ '("libseccomp"))))))
+
(define-public libosinfo
(package
(name "libosinfo")