summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 06:29:27 -0800
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 21:38:08 +0100
commit156b08bd2fcd7dc66d59f2312ddce3f04a28007c (patch)
tree608cba7d2648f12b987733bd6b91bebcc9621f93
parent3ac12ca61bbe887f2ebc8cfbf9b09a179f30a849 (diff)
downloadpatches-156b08bd2fcd7dc66d59f2312ddce3f04a28007c.tar
patches-156b08bd2fcd7dc66d59f2312ddce3f04a28007c.tar.gz
gnu: stylish-haskell: Update description.
* gnu/packages/haskell-apps.scm (stylish-haskell): Update description. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell-apps.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index f5b45d0bfb..12cb857cbb 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -754,8 +754,26 @@ advanced user's otherwise working script to fail under future circumstances.
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
(home-page "https://github.com/jaspervdj/stylish-haskell")
(synopsis "Haskell code prettifier")
- (description
- "A simple Haskell code prettifier. The goal is not to format all of the
-code in a file, just clean up import statements and a few other tedious
-items. This tool tries to help where necessary without getting in the way.")
+ (description "Stylish-haskell is a Haskell code prettifier. The goal is
+not to format all of the code in a file, to avoid \"getting in the way\".
+However, this tool can e.g. clean up import statements and help doing various
+tasks that get tedious very quickly. It can
+@itemize
+@item
+Align and sort @code{import} statements
+@item
+Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
+pragmas
+@item
+Remove trailing whitespaces
+@item
+Align branches in @code{case} and fields in records
+@item
+Convert line endings (customisable)
+@item
+Replace tabs by four spaces (turned off by default)
+@item
+Replace some ASCII sequences by their Unicode equivalent (turned off by
+default)
+@end itemize")
(license license:bsd-3)))