summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 06:32:00 -0800
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 21:38:08 +0100
commit08c62ac7bdd7c8c90bfa21dfb02008e4c2662e51 (patch)
treee6af37fcdf97c0279bbbcb9add4cd1cab72b875e
parent156b08bd2fcd7dc66d59f2312ddce3f04a28007c (diff)
downloadpatches-08c62ac7bdd7c8c90bfa21dfb02008e4c2662e51.tar
patches-08c62ac7bdd7c8c90bfa21dfb02008e4c2662e51.tar.gz
gnu: ghc-stylish-haskell: Deprecate older duplicate package.
* gnu/packages/haskell-xyz.scm (ghc-stylish-haskell): Deprecate it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell-xyz.scm63
1 files changed, 1 insertions, 62 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 261bc57305..0828dc93c6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11119,68 +11119,7 @@ occurrences of a substring (the first in case of overlaps) with another.")
(license license:bsd-3)))
(define-public ghc-stylish-haskell
- (package
- (name "ghc-stylish-haskell")
- (version "0.9.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://hackage/package/stylish-haskell/stylish-haskell-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "1ls11fdx6snvfx8yykpidz142zzxwi5bazl49hgfqlwx50rqcp7w"))))
- (build-system haskell-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'update-constraints
- (lambda _
- (substitute* "stylish-haskell.cabal"
- (("haskell-src-exts >= 1\\.18 && < 1\\.21,")
- "haskell-src-exts >= 1.18 && < 1.22,"))
- #t)))))
- (inputs
- `(("ghc-aeson" ,ghc-aeson)
- ("ghc-file-embed" ,ghc-file-embed)
- ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
- ("ghc-semigroups" ,ghc-semigroups)
- ("ghc-syb" ,ghc-syb)
- ("ghc-yaml" ,ghc-yaml)
- ("ghc-strict" ,ghc-strict)
- ("ghc-optparse-applicative"
- ,ghc-optparse-applicative)))
- (native-inputs
- `(("ghc-hunit" ,ghc-hunit)
- ("ghc-test-framework" ,ghc-test-framework)
- ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
- (home-page "https://github.com/jaspervdj/stylish-haskell")
- (synopsis "Haskell code prettifier")
- (description "Stylish-haskell is a Haskell code prettifier. The goal is
-not to format all of the code in a file, to avoid \"getting in the way\".
-However, this tool can e.g. clean up import statements and help doing various
-tasks that get tedious very quickly. It can
-@itemize
-@item
-Align and sort @code{import} statements
-@item
-Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
-pragmas
-@item
-Remove trailing whitespaces
-@item
-Align branches in @code{case} and fields in records
-@item
-Convert line endings (customisable)
-@item
-Replace tabs by four spaces (turned off by default)
-@item
-Replace some ASCII sequences by their Unicode equivalent (turned off by
-default)
-@end itemize")
- (license license:bsd-3)))
+ (deprecated-package "ghc-stylish-haskell" stylish-haskell))
(define-public ghc-svg-builder
(package