summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-20 21:13:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 22:41:59 +0100
commite5023bfd2a0a51f84c5f9c59fda724db59c97cc8 (patch)
tree3152f15dedaa928d579ca066e8fb2b0a711286cc
parent463e98357bda9ce33aa3cc149418108b25bd1c16 (diff)
downloadpatches-e5023bfd2a0a51f84c5f9c59fda724db59c97cc8.tar
patches-e5023bfd2a0a51f84c5f9c59fda724db59c97cc8.tar.gz
gnu: python-pendulum: Update to 2.1.0.
* gnu/packages/time.scm (python-pendulum): Update to 2.1.0. [native-inputs]: Remove. [arguments]: New field. [propagated-inputs]: Remove PYTHON-TZLOCAL.
-rw-r--r--gnu/packages/time.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index bb5351e900..f4dc8a2ffd 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -138,22 +138,21 @@ saving time. Almost all of the Olson timezones are supported.")
(define-public python-pendulum
(package
(name "python-pendulum")
- (version "1.2.4")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pendulum" version))
(sha256
(base32
- "1fj36yxi2f4lzchzd8ny1qjl67dbypnk0gn8qwad2w78579m8m8z"))))
+ "1zhzk0ai8is8zclw4v73dllf0hx0l5nmm4sbwrh6cl8h5qsang09"))))
(build-system python-build-system)
- (native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-nose" ,python-nose)))
+ ;; XXX: The PyPI distribution lacks tests, and the upstream repository
+ ;; lacks a setup.py!
+ (arguments '(#:tests? #f))
(propagated-inputs
`(("python-dateutil" ,python-dateutil)
- ("python-pytzdata" ,python-pytzdata)
- ("python-tzlocal" ,python-tzlocal)))
+ ("python-pytzdata" ,python-pytzdata)))
(home-page "https://github.com/sdispater/pendulum")
(synopsis "Alternate API for Python datetimes")
(description "Pendulum is a drop-in replacement for the standard