summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-21 11:58:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 11:58:26 +0100
commitdcff9bda97d088a717d6f7c01bdf7c0e68d62b9b (patch)
treedee078e1f5e8622e023a474fa8b063259160f6db
parent8198c19c127a02eb238a59a15c17aa2100ce9574 (diff)
downloadpatches-dcff9bda97d088a717d6f7c01bdf7c0e68d62b9b.tar
patches-dcff9bda97d088a717d6f7c01bdf7c0e68d62b9b.tar.gz
gnu: python-language-server: Build with python-jedi@0.15.2.
* gnu/packages/python-xyz.scm (python-language-server)[propagated-inputs]: Remove PYTHON-JEDI. Add PYTHON-JEDI-0.15. (python-jedi-0.15, python-parso-0.5): New public variables.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eaa17f3736..3937bad5c3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3459,7 +3459,9 @@ Server (PLS).")
(propagated-inputs
`(("python-pluggy" ,python-pluggy)
("python-jsonrpc-server" ,python-jsonrpc-server)
- ("python-jedi" ,python-jedi)
+ ;; Note: Remove the special versions of Jedi and Parso when updating
+ ;; this package.
+ ("python-jedi" ,python-jedi-0.15)
("python-yapf" ,python-yapf)
("python-pyflakes" ,python-pyflakes)
("python-pydocstyle" ,python-pydocstyle)
@@ -11566,6 +11568,20 @@ well.")
(define-public python2-jedi
(package-with-python2 python-jedi))
+;; python-language-server requires 0.15 specifically. Remove once unused.
+(define-public python-jedi-0.15
+ (package
+ (inherit python-jedi)
+ (version "0.15.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jedi" version))
+ (sha256
+ (base32
+ "01zqasl690x1i6dq4mvh13pz0cw8i276xsivsrnn00x90iqm42g9"))))
+ (propagated-inputs
+ `(("python-parso" ,python-parso-0.5)))))
+
(define-public ptpython
(package
(name "ptpython")
@@ -15885,6 +15901,19 @@ Parso is also able to list multiple syntax errors in your Python file.")
(define-public python2-parso
(package-with-python2 python-parso))
+;; This version is required for Jedi@0.15, which in turn is needed for
+;; python-language-server.
+(define-public python-parso-0.5
+ (package
+ (inherit python-parso)
+ (version "0.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "parso" version))
+ (sha256
+ (base32
+ "1qgvrkpma7vylrk047mxxvqd66nwqk978n3ig2w8iz9m3bgjbksm"))))))
+
(define-public python-async-generator
(package
(name "python-async-generator")