summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-20 21:39:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 22:41:59 +0100
commit9f9335277f0262af89d5d33fff4a0f09892efb3e (patch)
treea2969c9d426f8896b0329ec65d79ebeb489d8744
parente5023bfd2a0a51f84c5f9c59fda724db59c97cc8 (diff)
downloadpatches-9f9335277f0262af89d5d33fff4a0f09892efb3e.tar
patches-9f9335277f0262af89d5d33fff4a0f09892efb3e.tar.gz
gnu: Add python-text-unidecode.
* gnu/packages/python-xyz.scm (python-text-unidecode, python2-text-unidecode): New public variables.
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c3b06a58aa..ed5fba5282 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2398,6 +2398,40 @@ somewhat intelligible.")
(define-public python2-unidecode
(package-with-python2 python-unidecode))
+(define-public python-text-unidecode
+ (package
+ (name "python-text-unidecode")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "text-unidecode" version))
+ (sha256
+ (base32
+ "14xb99fdv52j21dsljgsbmbaqv10ps4b453p229r29sdn4xn1mms"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/kmike/text-unidecode/")
+ (synopsis "Decode Unicode data")
+ (description
+ "@code{text-unidecode} is a basic Python port of the @code{Text::Unidecode}
+Perl library. It can create ASCII representations of Unicode data. In general
+users should prefer the @code{python-unidecode} package which offers better
+memory usage and transliteration quality.")
+ ;; The user can choose either license.
+ (license (list license:clarified-artistic license:gpl2+))))
+
+(define-public python2-text-unidecode
+ (package-with-python2 python-text-unidecode))
+
(define-public python-pyjwt
(package
(name "python-pyjwt")