summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author6033fe7de85d <6033fe7de85d@airmail.cc>2020-03-18 18:56:33 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-21 15:41:51 +0100
commit6a65ec0945ef5a39073ffe06f51cbacd641883aa (patch)
tree4a5a38c6579e8f983fd3366323850f1d729f5b5b
parent93a267b7a40a762a66fa5149336f2c5545cbed30 (diff)
downloadpatches-6a65ec0945ef5a39073ffe06f51cbacd641883aa.tar
patches-6a65ec0945ef5a39073ffe06f51cbacd641883aa.tar.gz
gnu: Add emacs-objed.
*gnu/packages/emacs-xyz.scm (emacs-objed): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 62217e37f5..1ea3155807 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21711,3 +21712,25 @@ a @samp{date} keywords, and optionally, a @samp{filetags} keyword.")
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
conversion program}, a Japanese input method on Emacs.")
(license license:gpl2+))))
+
+(define-public emacs-objed
+ (package
+ (name "emacs-objed")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/objed-" version ".tar"))
+ (sha256
+ (base32
+ "1s38d6bvggdk5p45ww1jb4gxifzgjwgw1m6ar920nlg0j4fgbcvr"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/clemera/objed")
+ (synopsis "Navigate and edit text objects")
+ (description
+ "@code{emacs-objed} allows to navigate and edit text objects. It
+enables modal editing and composition of commands, too. It combines ideas of
+other Editors like Vim or Kakoune and tries to align them with regular Emacs
+conventions.")
+ (license license:gpl3+)))