summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-19 10:54:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-19 22:33:26 +0200
commit40b9f388767c9cae409277194724dad708a18d95 (patch)
treed3b3369aaebc9f550136195d452f502dd14ed9d3
parent930d8c5a2107a85a76c302d2f1440b37f077fff7 (diff)
downloadpatches-40b9f388767c9cae409277194724dad708a18d95.tar
patches-40b9f388767c9cae409277194724dad708a18d95.tar.gz
gnu: Add rust-fragile-0.3.
* gnu/packages/crates-io.scm (rust-fragile-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5efa6b8e6e..4391b46376 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5562,6 +5562,26 @@ implementation that is more efficient for smaller hash keys.")
(base32
"0jxgzd04ra4imjv8jgkmdq59kj8fsz6w4zxsbmlai34h26225c00"))))))
+(define-public rust-fragile-0.3
+ (package
+ (name "rust-fragile")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fragile" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yf2hmkw52x2dva3c9km1x8c2z5kwby7qqn8kz5ms3gs480i9y05"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/mitsuhiko/rust-fragile")
+ (synopsis "Wrapper types for sending non-send values to other threads")
+ (description "This package provides wrapper types for sending non-send
+values to other threads.")
+ (license license:asl2.0)))
+
(define-public rust-freetype-rs-0.23
(package
(name "rust-freetype-rs")