summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-03-19 13:29:05 +0530
committerDanny Milosavljevic <dannym@scratchpost.org>2020-03-21 14:13:00 +0100
commit1163dacd4b4d9d274be5e8393072323435e9236a (patch)
treec68d472a548b1f59e8968adabc1fbc8d1d7f0d47
parentbbeb710de70521010b3d432cb5b4b14ce6e45ca6 (diff)
downloadpatches-1163dacd4b4d9d274be5e8393072323435e9236a.tar
patches-1163dacd4b4d9d274be5e8393072323435e9236a.tar.gz
gnu: Add r-crochet.
* gnu/packages/cran.scm (r-crochet): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2ef1b931a8..a001e135e6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20802,3 +20802,24 @@ statistics and p-values of the correlation coefficients.")
scales and utilities, including a spell check function for plot label fields
and an overall emphasis on typography.")
(license license:expat)))
+
+(define-public r-crochet
+ (package
+ (name "r-crochet")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "crochet" version))
+ (sha256
+ (base32
+ "1cbv79nyycxk6f8ldcsnn2pvgxqlnrj0qs19nhafnq2clxy863k6"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/agrueneberg/crochet")
+ (synopsis "Implementation Helper for Matrix-Like Types")
+ (description
+ "Functions to help implement the extraction / subsetting / indexing
+function @code{[} and replacement function @code{[<-} of custom matrix-like
+types (based on S3, S4, etc.), modeled as closely to the base matrix class
+as possible (with tests to prove it).")
+ (license license:expat)))