summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-18 12:15:50 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-11 11:03:27 +0200
commitc90a4baff6cbc35ccd6af3cdac72f314c9eceab3 (patch)
tree9f35974f4bd0c0146d57ecafc0a73195ca94a559
parent936e7d67746a2c769c73692949da1f5a1abf94f9 (diff)
downloadpatches-c90a4baff6cbc35ccd6af3cdac72f314c9eceab3.tar
patches-c90a4baff6cbc35ccd6af3cdac72f314c9eceab3.tar.gz
gnu: Add r-bsgenome-hsapiens-ucsc-hg19.
* gnu/packages/bioinformatics.scm (r-bsgenome-hsapiens-ucsc-hg19): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8b0132d91a..58268dc258 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4769,6 +4769,37 @@ plots the corresponding sequence logo as introduced by Schneider and
Stephens (1990).")
(license license:lgpl2.0+)))
+(define-public r-bsgenome-hsapiens-ucsc-hg19
+ (package
+ (name "r-bsgenome-hsapiens-ucsc-hg19")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "http://www.bioconductor.org/packages/"
+ "release/data/annotation/src/contrib/"
+ "BSgenome.Hsapiens.UCSC.hg19_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1y0nqpk8cw5a34sd9hmin3z4v7iqm6hf6l22cl81vlbxqbjibxc8"))))
+ (properties
+ `((upstream-name . "BSgenome.Hsapiens.UCSC.hg19")))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)))
+ (home-page
+ "http://www.bioconductor.org/packages/BSgenome.Hsapiens.UCSC.hg19/")
+ (synopsis "Full genome sequences for Homo sapiens")
+ (description
+ "This package provides full genome sequences for Homo sapiens as provided
+by UCSC (hg19, February 2009) and stored in Biostrings objects.")
+ (license license:artistic2.0)))
+
(define-public r-qtl
(package
(name "r-qtl")