summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-16 16:15:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-16 16:15:41 +0100
commitee94ca11a1d695871c11cd5cf521089d5bcdb34f (patch)
tree0d875ea577b1890d91683933be4b68bfef7a50bc
parent752eb9e0d86931de9eb42d1a60069e48ac1fbfd8 (diff)
downloadpatches-ee94ca11a1d695871c11cd5cf521089d5bcdb34f.tar
patches-ee94ca11a1d695871c11cd5cf521089d5bcdb34f.tar.gz
gnu: python-beautifulsoup4: Fix python2 variant.
This is a followup to 5f37f0b66e301210698ab0c0af24453c826ba18a. * gnu/packages/python.scm (python-beautifulsoup4)[properties]: New field. Delay python2 variant.
-rw-r--r--gnu/packages/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8af6965b1e..9388534c98 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5232,7 +5232,8 @@ screen-scraping projects. It offers Pythonic idioms for navigating,
searching, and modifying a parse tree, providing a toolkit for
dissecting a document and extracting what you need. It automatically
converts incoming documents to Unicode and outgoing documents to UTF-8.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-beautifulsoup4))))))
(define-public python2-beautifulsoup4
(package