summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-20 00:38:11 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:20 +0100
commitdd80d13bea8239dc77518204cfaa8aee8c8ac097 (patch)
treea7ee12dcce143b4d361e9507c5a446c5aa4cc5a8
parent86633b2218ea8a1eb3573cea5b76b49f71667eba (diff)
downloadpatches-dd80d13bea8239dc77518204cfaa8aee8c8ac097.tar
patches-dd80d13bea8239dc77518204cfaa8aee8c8ac097.tar.gz
gnu: Add knotes.
* gnu/packages/kde-pim.scm (knotes): NEw variable.
-rw-r--r--gnu/packages/kde-pim.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 661962bb46..137176e481 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1151,6 +1151,80 @@ US-ASCII, non-text attachments, multi-part message bodies, and header
information in non-ASCII character sets.")
(license license:lgpl2.0+)))
+(define-public knotes
+ (package
+ (name "knotes")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/knotes-" version ".tar.xz"))
+ (sha256
+ (base32 "128qpfqjn5zwl5550srmbjyxns242q6a3b0jy70jjx2yixy3rb87"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("libxslt" ,libxslt)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("akonadi-contacts" ,akonadi-contacts)
+ ("akonadi-mime" ,akonadi-mime)
+ ("akonadi-notes" ,akonadi-notes)
+ ("akonadi-search" ,akonadi-search)
+ ("boost" ,boost)
+ ("grantlee" ,grantlee)
+ ("grantleetheme" ,grantleetheme)
+ ("kcalendarcore" ,kcalendarcore)
+ ("kcalutils" ,kcalutils)
+ ("kcmutils" ,kcmutils)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcontacts" ,kcontacts)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdnssd" ,kdnssd)
+ ("kdoctools" ,kdoctools)
+ ("kglobalaccel" ,kglobalaccel)
+ ("kiconthemes" ,kiconthemes)
+ ("kimap" ,kimap)
+ ("kitemmodels" ,kitemmodels)
+ ("kitemviews" ,kitemviews)
+ ("kmime" ,kmime)
+ ("kmime" ,kmime)
+ ("knewstuff" ,knewstuff)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kontactinterface" ,kontactinterface)
+ ("kparts" ,kparts)
+ ("kpimcommon" ,kpimcommon)
+ ("kpimtextedit" ,kpimtextedit)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdepim" ,libkdepim)
+ ("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://kontact.kde.org/components/knotes.html")
+ (synopsis "Note-taking utility")
+ (description "KNotes lets you write the computer equivalent of sticky
+notes. The notes are saved automatically when you exit the program, and they
+display when you open the program.
+
+Features:
+@itemize
+@item Write notes in your choice of font and background color
+@item Use drag and drop to email your notes
+@item Can be dragged into Calendar to book a time-slot
+@item Notes can be printed
+@end itemize")
+ (license (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kontactinterface
(package
(name "kontactinterface")