summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-20 01:28:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:22 +0100
commit992c6d29bbdb3663d9b5fa1ddf3fdd25e2944360 (patch)
tree15ab189d71ff9a00a5b50360ec927c6d763d3025
parentb3359b85985bf64061ace2154e2414fb482443bf (diff)
downloadpatches-992c6d29bbdb3663d9b5fa1ddf3fdd25e2944360.tar
patches-992c6d29bbdb3663d9b5fa1ddf3fdd25e2944360.tar.gz
gnu: Add kincidenceeditor.
* gnu/packages/kde-pim.scm (kincidenceeditor): New variable.
-rw-r--r--gnu/packages/kde-pim.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 966cf5fa84..048a465e86 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -335,6 +335,55 @@ Akonadi PIM data server. It uses Xapian for indexing and querying.")
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0+))))
+(define-public kincidenceeditor
+ (package
+ (name "kincidenceeditor")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/incidenceeditor-" version ".tar.xz"))
+ (sha256
+ (base32 "0v962v2ihawndg39ypkfawa449vpbdyg00ib7avb19a153y3wxg6"))))
+ (properties `((upstream-name . "incidenceeditor")))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("akonadi-calendar" ,akonadi-calendar)
+ ("akonadi-contacts" ,akonadi-contacts)
+ ("akonadi-mime" ,akonadi-mime)
+ ("boost" ,boost)
+ ("kcalendarcore" ,kcalendarcore)
+ ("kcalendarsupport" ,kcalendarsupport)
+ ("kcalutils" ,kcalutils)
+ ("kcodecs" ,kcodecs)
+ ("kcontacts" ,kcontacts)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdepim-apps-libs" ,kdepim-apps-libs)
+ ("kdiagram" ,kdiagram)
+ ("keventviews" ,keventviews)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kidentitymanagement" ,kidentitymanagement)
+ ("kio" ,kio)
+ ("kitemmodels" ,kitemmodels)
+ ("kldap" ,kldap)
+ ("kmailtransport" ,kmailtransport)
+ ("kmime" ,kmime)
+ ("kpimtextedit" ,kpimtextedit)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwallat" ,kwallet)
+ ("libkdepim" ,libkdepim)
+ ("qtbase" ,qtbase)))
+ (home-page "https://cgit.kde.org/incidenceeditor.git")
+ (synopsis "KDE PIM library for editing incidences")
+ (description "This library provides an incidence editor for KDE PIM.")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kaddressbook
(package
(name "kaddressbook")