summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-19 23:58:11 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:20 +0100
commit86633b2218ea8a1eb3573cea5b76b49f71667eba (patch)
tree1838e7c64b03dadf85ceaba7b9d6f86ce7362970
parentde6b78220475e604fa105ccf98aabb92e86658f3 (diff)
downloadpatches-86633b2218ea8a1eb3573cea5b76b49f71667eba.tar
patches-86633b2218ea8a1eb3573cea5b76b49f71667eba.tar.gz
gnu: Add kaddressbook.
* gnu/packages/kde-pim.scm (kaddressbook): New variable.
-rw-r--r--gnu/packages/kde-pim.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 0956deece3..661962bb46 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -335,6 +335,63 @@ Akonadi PIM data server. It uses Xapian for indexing and querying.")
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0+))))
+(define-public kaddressbook
+ (package
+ (name "kaddressbook")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kaddressbook-" version ".tar.xz"))
+ (sha256
+ (base32 "1bpl9cqjv7s6pnsaa266jqmny2s6ldkylxviri162jxg51v1hhz3"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("akonadi-contacts" ,akonadi-contacts)
+ ("akonadi-mime" ,akonadi-mime)
+ ("akonadi-search" ,akonadi-search)
+ ("boost" ,boost)
+ ("gpgme" ,gpgme)
+ ("grantlee" ,grantlee)
+ ("grantleetheme" ,grantleetheme)
+ ("kcalendarcore" ,kcalendarcore)
+ ("kcmutils" ,kcmutils)
+ ("kcompletion" ,kcompletion)
+ ("kcontacts" ,kcontacts)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdepim-apps-libs" ,kdepim-apps-libs)
+ ("kdoctools" ,kdoctools)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kimap" ,kimap)
+ ("kio" ,kio)
+ ("kitemmodels" ,kitemmodels)
+ ("kmime" ,kmime)
+ ("kontactinterface" ,kontactinterface)
+ ("kparts" ,kparts)
+ ("kpimcommon" ,kpimcommon)
+ ("kpimtextedit" ,kpimtextedit)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdepim" ,libkdepim)
+ ("libkleo" ,libkleo)
+ ("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
+ ("prison" ,prison)
+ ("qgpgme" ,qgpgme)
+ ("qtbase" ,qtbase)))
+ (home-page "https://kontact.kde.org/components/kaddressbook.html")
+ (synopsis "Address Book application to manage your contacts")
+ (description "KAddressBook stores all the personal details of your family,
+friends and other contacts. It supports large variety of services, including
+NextCloud, Kolab, Google Contacts, Microsoft Exchange (EWS) or any standard
+CalDAV server.")
+ (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
(define-public kalarmcal
(package
(name "kalarmcal")