summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-18 21:47:00 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:18 +0100
commit83a4ab4e4213eaf10289f0abd8a43979178701d7 (patch)
treefe04b2640f16e7e5b70160479f485e4971b4d4c7
parentea2a180f68156ac05b435e953cd1231274244b9c (diff)
downloadpatches-83a4ab4e4213eaf10289f0abd8a43979178701d7.tar
patches-83a4ab4e4213eaf10289f0abd8a43979178701d7.tar.gz
gnu: Add libksieve.
* gnu/packages/kde-pim.scm (libksieve): New variable. * gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch: New file. * gnu/local.mk: Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/kde-pim.scm58
-rw-r--r--gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch59
3 files changed, 118 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index caa73d44d4..aa5dcd7c39 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1108,6 +1108,7 @@ dist_patch_DATA = \
%D%/packages/patches/libjxr-fix-function-signature.patch \
%D%/packages/patches/libjxr-fix-typos.patch \
%D%/packages/patches/libotr-test-auth-fix.patch \
+ %D%/packages/patches/libksieve-Fix-missing-lInk-libraries.patch \
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
%D%/packages/patches/libmad-length-check.patch \
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 07293b6bd1..fbe9bc2e94 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1132,3 +1132,61 @@ various Google services.")
KDE using certificate-based crypto.")
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0+))))
+
+(define-public libksieve
+ (package
+ (name "libksieve")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/libksieve-" version ".tar.xz"))
+ (sha256
+ (base32 "0q6f6lc4yvlq0vsfml10lz844z6zxxf7yivk7l3vglap58ci20x1"))
+ (patches (search-patches "libksieve-Fix-missing-link-libraries.patch"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("cyrus-sasl" ,cyrus-sasl)
+ ("karchive" ,karchive)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kidentitymanagement" ,kidentitymanagement)
+ ("kimap" ,kimap)
+ ("kio" ,kio)
+ ("kmailtransport" ,kmailtransport)
+ ("kmime" ,kmime)
+ ("knewstuff" ,knewstuff)
+ ("kpimcommon" ,kpimcommon)
+ ("kpimtextedit" ,kpimtextedit)
+ ("ksyntaxhighlighting" ,ksyntaxhighlighting)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwallet" ,kwallet)
+ ("kwindowsystem" ,kwindowsystem)
+ ("libkdepim" ,libkdepim)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebengine" ,qtwebengine)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'substitute
+ (lambda _
+ ;; Disable a failing test
+ ;; sieveeditorhelphtmlwidgettest fails with `sigtrap`
+ (substitute*
+ "src/ksieveui/editor/webengine/autotests/CMakeLists.txt"
+ (("^\\s*(add_test|ecm_mark_as_test)\\W" line)
+ (string-append "# " line)))
+ #t)))))
+ (home-page "https://cgit.kde.org/libksieve.git")
+ (synopsis "KDE Sieve library")
+ (description "Sieve is a language that can be used filter emails. KSieve
+is a Sieve parser and interpreter library for KDE.")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0+))))
diff --git a/gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch b/gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch
new file mode 100644
index 0000000000..238c4ec46c
--- /dev/null
+++ b/gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch
@@ -0,0 +1,59 @@
+From 732861dda9c466841a09329a0b2c992f2b78c40a Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Tue, 21 Jan 2020 23:15:23 +0100
+Subject: [PATCH] Fix missing link libraries.
+
+See <https://phabricator.kde.org/D26818>
+
+These are only actually missing if the libraries reside in different
+prefixes, as it is the case in Guix or Nix.
+---
+ src/ksieveui/autocreatescripts/tests/CMakeLists.txt | 2 ++
+ src/ksieveui/scriptsparsing/autotests/CMakeLists.txt | 2 +-
+ src/ksieveui/scriptsparsing/tests/CMakeLists.txt | 8 ++++++--
+ 3 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/src/ksieveui/autocreatescripts/tests/CMakeLists.txt b/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
+index 8a482b4..c43216c 100644
+--- a/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
++++ b/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
+@@ -15,6 +16,7 @@ set(parsingscript_gui_SRCS parsingscript_gui.cpp ../../tests/capability.cpp)
+ add_executable(parsingscript_gui ${parsingscript_gui_SRCS})
+ target_link_libraries(parsingscript_gui
+ KF5::KIOCore
++ KF5::SyntaxHighlighting
+ KF5::KSieveUi
+ KF5::KSieve
+ KF5::PimCommon
+diff --git a/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt b/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
+index e41a74e..31703ef 100644
+--- a/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
++++ b/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
+@@ -5,7 +5,7 @@ macro(add_sieveeditor_xmlprintingscriptbuilding _source _extrasource)
+ ecm_add_test(${_test}
+ TEST_NAME ${_name}
+ NAME_PREFIX "sieveeditor-xmlprintingscriptbuilding-"
+- LINK_LIBRARIES Qt5::Test KF5::I18n KF5::KSieveUi
++ LINK_LIBRARIES Qt5::Test KF5::I18n KF5::KSieveUi KF5::SyntaxHighlighting
+ )
+ endmacro()
+ add_sieveeditor_xmlprintingscriptbuilding(xmlprintingscriptbuildertest.cpp "" "")
+diff --git a/src/ksieveui/scriptsparsing/tests/CMakeLists.txt b/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
+index a252039..99a1aaa 100644
+--- a/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
++++ b/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
+@@ -9,5 +9,9 @@ set(xmlsieveparsing_SRCS
+ )
+
+ add_executable(xmlsieveparsing ${xmlsieveparsing_SRCS} )
+-target_link_libraries(xmlsieveparsing KF5::KSieveUi KF5::KSieve KF5::I18n)
+-
++target_link_libraries(xmlsieveparsing
++ KF5::KSieveUi
++ KF5::SyntaxHighlighting
++ KF5::KSieve
++ KF5::I18n
++)
+--
+2.21.1
+