summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 12:26:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:03 +0200
commit356230da4a77eef1345e4b2079db7020df98cdc6 (patch)
tree18eb0a7d45aa662519c296c1336aa41b52860819
parent3b0153bd828f68804f7226ca655d26aaa1a0c065 (diff)
downloadpatches-356230da4a77eef1345e4b2079db7020df98cdc6.tar
patches-356230da4a77eef1345e4b2079db7020df98cdc6.tar.gz
gnu: Add r-fansi.
* gnu/packages/cran.scm (r-fansi): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 016d1b1e41..be64aa3a98 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4424,6 +4424,27 @@ packages. It contains also functions for simplifying some clustering analysis
steps and provides ggplot2-based elegant data visualization.")
(license license:gpl2)))
+(define-public r-fansi
+ (package
+ (name "r-fansi")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fansi" version))
+ (sha256
+ (base32
+ "135qj7bcc3mwn0vg55hiiadf66lx6zaxvkicfmfw9x0zr7ah2r6x"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("r-knitr" ,r-knitr))) ; for vignettes
+ (home-page "https://github.com/brodieG/fansi")
+ (synopsis "ANSI control sequence aware string functions")
+ (description
+ "This package provides counterparts to R string manipulation functions
+that account for the effects of ANSI text formatting control sequences.")
+ (license license:gpl2+)))
+
(define-public r-nbclust
(package
(name "r-nbclust")