summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:05:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:54 +0100
commit19172e12ef990f9c7527a90fe24ab3e38a348974 (patch)
treecb2f991c10865c93ef83a913ef414601e26d013d
parentcb350053dab549e9bbd85aec651e3662a9f68062 (diff)
downloadpatches-19172e12ef990f9c7527a90fe24ab3e38a348974.tar
patches-19172e12ef990f9c7527a90fe24ab3e38a348974.tar.gz
gnu: Add r-seewave.
* gnu/packages/cran.scm (r-seewave): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b1217ad992..0f0ecb6829 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17397,3 +17397,29 @@ representation in various ways, read MP3, read MIDI, perform steps of a
transcription, ...")
;; Either of these versions.
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-seewave
+ (package
+ (name "r-seewave")
+ (version "2.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "seewave" version))
+ (sha256
+ (base32
+ "1qg8f5gik9pw6f9mcxqmrc9x3003s8vdm6g01pjjpyc9qaqiz2vi"))))
+ (properties `((upstream-name . "seewave")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-tuner" ,r-tuner)))
+ (home-page "http://rug.mnhn.fr/seewave")
+ (synopsis "Sound analysis and synthesis")
+ (description
+ "This package provides functions for analysing, manipulating, displaying,
+editing and synthesizing time waves (particularly sound). This package
+processes time analysis (oscillograms and envelopes), spectral content,
+resonance quality factor, entropy, cross correlation and autocorrelation,
+zero-crossing, dominant frequency, analytic signal, frequency coherence, 2D
+and 3D spectrograms and many other analyses.")
+ (license license:gpl2+)))