summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-03-18 20:59:49 -0500
committerGuix Patches Tester <>2020-03-19 05:48:13 +0000
commite72b01bbd1ea686653bfc2de1379f878c86b7d36 (patch)
tree996ab5ea4c518282a38e74cebecf709f7671507d
parent58d902741240d52d783e77ef3a0540642bd91e4c (diff)
downloadpatches-e72b01bbd1ea686653bfc2de1379f878c86b7d36.tar
patches-e72b01bbd1ea686653bfc2de1379f878c86b7d36.tar.gz
gnu: Add emacs-pretty-hydra.
* gnu/packages/emacs-xyz.scm (emacs-pretty-hydra): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6682403ebc..477ecbdc87 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5577,6 +5577,40 @@ the Hydra very seamless; it's like a minor mode that disables itself
automatically.")
(license license:gpl3+)))
+(define-public emacs-pretty-hydra
+ (package
+ (name "emacs-pretty-hydra")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jerrypnz/major-mode-hydra.el.git")
+ (commit version)))
+ (sha256
+ (base32
+ "08a15knkdq35pzjq82imff016fbfdib5q4glg2xmdy2b5fnk7jqa"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-hydra" ,emacs-hydra)
+ ("emacs-s" ,emacs-s)
+ ("emacs-dash" ,emacs-dash)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'add-source-to-load-path 'remove-pretty-hydra
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; major-mode-hydra is packaged separately.
+ (delete-file "major-mode-hydra.el")
+ #t)))))
+ (home-page "https://github.com/jerrypnz/major-mode-hydra.el")
+ (synopsis "Major mode keybindings managed by Hydra")
+ (description
+ "This package offers an hydra-based method of managing major
+mode-specific key bindings. It is intended for use as a library only; see
+package @code{emacs-major-mode-hydra} for a user-friendly interface.")
+ (license license:gpl3+)))
+
(define-public emacs-ivy
(package
(name "emacs-ivy")