summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorraingloom <raingloom@protonmail.com>2020-02-16 00:00:35 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-18 11:55:33 +0100
commitd0f501647587154c4763b6c42e3c17adb83f01d0 (patch)
tree9fb04da8e0da53bdfe43dfe91cf7f14b0edc7ab6
parent370cb2e0a493ca7efcac02a43606d8f69f73c2c7 (diff)
downloadpatches-d0f501647587154c4763b6c42e3c17adb83f01d0.tar
patches-d0f501647587154c4763b6c42e3c17adb83f01d0.tar.gz
gnu: gspell: --enable-vala for VAPI (for geary)
* gnu/packages/gnome.scm (gspell)[arguments]: Add #:configure-flags. [native-inputs]: Add VALA. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0f9241edfc..8e77b5f76e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8946,7 +8946,8 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
(patches (search-patches "gspell-dash-test.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags (list "--enable-vala")
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
@@ -8971,6 +8972,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
`(("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
+ ("vala" ,vala) ;for VAPI, needed by Geary
("xmllint" ,libxml2)
;; For tests.