summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-02-19 11:18:53 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-18 11:55:33 +0100
commitaaa7d17dce91f00b7313ca93795cc84ec216a86a (patch)
tree43d425d316f672e7248b02546417b5533d0b6f4a
parente002332b8a136638c2a4fc1a2f2a26541ce0211d (diff)
downloadpatches-aaa7d17dce91f00b7313ca93795cc84ec216a86a.tar
patches-aaa7d17dce91f00b7313ca93795cc84ec216a86a.tar.gz
gnu: gnunet: Update to 0.12.2.
* gnu/packages/gnunet.scm (gnunet): Update to 0.12.2. [inputs]: Add libjpeg. [arguments]: Deactivate more tests, set LANG env variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnunet.scm32
1 files changed, 28 insertions, 4 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index f9b71a2f3a..1bcff1bf66 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -249,7 +250,7 @@ supports HTTP, HTTPS and GnuTLS.")
(define-public gnunet
(package
(name "gnunet")
- (version "0.11.8")
+ (version "0.12.2")
(source
(origin
(method url-fetch)
@@ -257,7 +258,7 @@ supports HTTP, HTTPS and GnuTLS.")
".tar.gz"))
(sha256
(base32
- "1zkmcq75sfr3iyg8rgxp9dbl7fwsvc1a71rc0vgisghcbrx1n7yj"))))
+ "1mwcy7fj1rpd39w7j7k3jdwlil5s889b2qlhfdggqmhigl28na5c"))))
(build-system gnu-build-system)
(inputs
`(("bluez" ,bluez)
@@ -269,6 +270,7 @@ supports HTTP, HTTPS and GnuTLS.")
("libextractor" ,libextractor)
("libidn" ,libidn2)
("libgcrypt" ,libgcrypt)
+ ("libjpeg" ,libjpeg)
("libltdl" ,libltdl)
("libmicrohttpd" ,libmicrohttpd)
("libogg" ,libogg)
@@ -289,11 +291,30 @@ supports HTTP, HTTPS and GnuTLS.")
#:phases
(modify-phases %standard-phases
(add-after 'configure 'remove-failing-tests
- ;; These tests fail in Guix's building envrionment.
+ ;; These tests fail in Guix's building environment.
(lambda _
+ (substitute* "src/cadet/Makefile"
+ (("test_cadet_2_reopen\\$\\(EXEEXT\\) \\\\\n") "test_cadet_2_reopen$(EXEEXT)")
+ (("test_cadet_5_forward\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_signal\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_keepalive\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_speed\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_speed_ack\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_speed_reliable\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_speed_reliable_backwards\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_speed_backwards\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_cadet_5_reopen\\$\\(EXEEXT\\)") ""))
(substitute* "src/transport/Makefile"
+ (("\\$\\(am__EXEEXT_15\\)") "") ; test_transport_api_https
+ (("test_transport_api_manipulation_cfg\\$\\(EXEEXT\\) \\\\\n") "")
(("test_transport_api_udp_nat\\$\\(EXEEXT\\) \\\\\n") "")
- (("test_transport_api_manipulation_cfg\\$\\(EXEEXT\\) \\\\\n") ""))
+ (("test_transport_blacklisting_multiple_plugins\\$\\(EXEEXT\\) \\\\\n") ""))
+ (substitute* "src/testbed/Makefile"
+ (("test_testbed_api_2peers_1controller\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_testbed_api_test\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_testbed_api_statistics\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_testbed_api_topology\\$\\(EXEEXT\\) \\\\\n") "")
+ (("test_testbed_api_topology_clique\\$\\(EXEEXT\\) \\\\\n") ""))
(substitute* "src/topology/Makefile"
(("^check_PROGRAMS.*") "\n")
(("test_gnunet_daemon_topology\\$\\(EXEEXT\\)\n") ""))
@@ -308,6 +329,9 @@ supports HTTP, HTTPS and GnuTLS.")
"src/transport/gnunet-transport-certificate-creation.in")
(("gnutls-certtool") "certtool"))
#t))
+ (add-before 'check 'set-env-var-for-tests
+ (lambda _
+ (setenv "LANG" "en_US.UTF-8")))
;; Swap 'check and 'install phases and add installed binaries to $PATH.
(add-before 'check 'set-path-for-check
(lambda* (#:key outputs #:allow-other-keys)