summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-30 15:22:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-30 15:22:33 +0200
commit79f04920b220661dd0d31a40ca60b536c86d4d5e (patch)
tree14cf53d1fd80b6845772c43ccc6e1c0153a04ae8
parentb03dd5cfc099426c5cb22477c3d75f7076c3bedd (diff)
downloadpatches-79f04920b220661dd0d31a40ca60b536c86d4d5e.tar
patches-79f04920b220661dd0d31a40ca60b536c86d4d5e.tar.gz
gnu: Add r-glasso.
* gnu/packages/cran.scm (r-glasso): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 426f054eee..ac9dfa2535 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14708,3 +14708,24 @@ This package simplifies the way to manipulate the HTML or LaTeX codes
generated by @code{kable()} and allows users to construct complex tables and
customize styles using a readable syntax.")
(license license:expat)))
+
+(define-public r-glasso
+ (package
+ (name "r-glasso")
+ (version "1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "glasso" version))
+ (sha256
+ (base32
+ "0nshpx14v2yny7lr8ll6nnz71n0f02sddh2c2dglfprbk89p9yp6"))))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "http://www-stat.stanford.edu/~tibs/glasso")
+ (synopsis "Graphical Lasso: estimation of Gaussian graphical models")
+ (description
+ "This is a package for estimation of a sparse inverse covariance matrix
+using a lasso (L1) penalty. Facilities are provided for estimates along a
+path of values for the regularization parameter.")
+ (license license:gpl2)))