summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-05-11 23:24:43 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-05-13 20:44:58 +0530
commit605ecbcb2a09289eece1e25de562d04d3c425019 (patch)
treec0aa165e56cc27ce7fb1e20e1f19d28b5c8db852
parent99d406c92d075219f8a53c59a9f1a10f1f6aaaa0 (diff)
downloadpatches-605ecbcb2a09289eece1e25de562d04d3c425019.tar
patches-605ecbcb2a09289eece1e25de562d04d3c425019.tar.gz
gnu: Add emacs-commander.
* gnu/packages/emacs.scm (emacs-commander): New variable.
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ccd70db41e..aef4aa5947 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4669,3 +4669,29 @@ strings to ANSI strings. Turning a string into an ANSI string can be to add
color to a text, add color in the background of a text or adding a style, such
as bold, underscore or italic.")
(license license:gpl3+)))
+
+;; Tests for emacs-commander have a circular dependency with ert-runner, and
+;; therefore cannot be run
+(define-public emacs-commander
+ (package
+ (name "emacs-commander")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rejeep/commander.el/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "196s2i15z7gwxa97l1wkxvjnfmj5n38wwm6d3g4zz15l2vqggc2y"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/rejeep/commander.el")
+ (synopsis "Emacs command line parser")
+ (description "@code{emacs-commander} provides command line parsing for
+Emacs.")
+ (license license:gpl3+)))