summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-03-18 12:26:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-18 12:26:28 +0100
commit382ba7bad59ec7205cd883bb93b5e6cf33329d66 (patch)
tree5ad3f7c0fbbe474a6cd363db06a362c8da35ea1e
parent0e26c3cfcf0e7fe74f942c5278a8fe6110a7ab38 (diff)
downloadpatches-382ba7bad59ec7205cd883bb93b5e6cf33329d66.tar
patches-382ba7bad59ec7205cd883bb93b5e6cf33329d66.tar.gz
gnu: Add emacs-org-static-blog.
* gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a821bc7776..932170f136 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21762,6 +21763,34 @@ records can be browsed and searched from the Emacs Calendar for convenience.
All entries in a specified TODO state will be carried over to the next day.")
(license license:bsd-3)))
+(define-public emacs-org-static-blog
+ ;; Use the latest commit as the last release only contains half of the
+ ;; current total commits. New release requested at
+ ;; <https://github.com/bastibe/org-static-blog/issues/50>.
+ (package
+ (name "emacs-org-static-blog")
+ (version "20200117")
+ (home-page "https://github.com/bastibe/org-static-blog")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "5c19300d7634e94ae813b1b66abc716fbb1e5fc9")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m7vmibjc6yk2npfrnnqd3g2099300r0q8mr8cvyivmk5ailbfrh"))))
+ (build-system emacs-build-system)
+ (synopsis
+ "Simple Org mode based static blog generator")
+ (description
+ "@code{emacs-org-static-blog} is one more static blog generator, it
+focuses on being simple. All file are simple Org files in a directory. The
+only requirement is that every Org file must have a @samp{title} and
+a @samp{date} keywords, and optionally, a @samp{filetags} keyword.")
+ (license license:bsd-3)))
+
(define-public emacs-ddskk
;; XXX: Upstream adds code names to their release tags, so version and code
;; name below need to be updated together.