summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-30 15:50:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-30 15:50:10 +0200
commit37120e7a2385cc6a4e5a3c955df810ed0e0b88aa (patch)
tree29763724ec130768e0436279a4ac33f33088bd6b
parentb46a0ee7532639817fe846233a75c758a9e7b963 (diff)
downloadpatches-37120e7a2385cc6a4e5a3c955df810ed0e0b88aa.tar
patches-37120e7a2385cc6a4e5a3c955df810ed0e0b88aa.tar.gz
gnu: Add r-rhpcblasctl.
* gnu/packages/cran.scm (r-rhpcblasctl): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ac9dfa2535..9eec520b8f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14729,3 +14729,24 @@ customize styles using a readable syntax.")
using a lasso (L1) penalty. Facilities are provided for estimates along a
path of values for the regularization parameter.")
(license license:gpl2)))
+
+(define-public r-rhpcblasctl
+ (package
+ (name "r-rhpcblasctl")
+ (version "0.18-205")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RhpcBLASctl" version))
+ (sha256
+ (base32
+ "1ls2286fvrp1g7p8v4l6axznychh3qndranfpzqz806cm9ml1cdp"))))
+ (properties `((upstream-name . "RhpcBLASctl")))
+ (build-system r-build-system)
+ (home-page "http://prs.ism.ac.jp/~nakama/Rhpc/")
+ (synopsis "Control the number of threads on BLAS")
+ (description
+ "This package allows you to control the number of threads the BLAS
+library uses. It is also possible to control the number of threads in
+OpenMP.")
+ (license license:agpl3+)))