summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-31 05:39:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-31 05:46:07 +0200
commit15b4c91163a54bfab1599999165313c3a7d13f84 (patch)
tree6a4f87911f241a15aba70ec80403c7673d984af6
parent9898a2d3451c1690df4924c39de9d4029b543934 (diff)
downloadpatches-15b4c91163a54bfab1599999165313c3a7d13f84.tar
patches-15b4c91163a54bfab1599999165313c3a7d13f84.tar.gz
gnu: python-glances: Don't check for updates by default.
* gnu/packages/python-xyz.scm (python-glances)[source]: Add snippet.
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 49e125afd6..98248e2a61 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10952,7 +10952,18 @@ command @command{natsort} that exposes this functionality in the command line.")
(uri (pypi-uri "Glances" version))
(sha256
(base32
- "07j1ggzsqiskyz1i4mrnyr9i95v0dqi0i0hibnv1l188km8shmi8"))))
+ "07j1ggzsqiskyz1i4mrnyr9i95v0dqi0i0hibnv1l188km8shmi8"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Glances phones PyPI for weekly update checks by default.
+ ;; Disable these. The user can re-enable them if desired.
+ (substitute* "glances/outdated.py"
+ (("^(.*)self\\.load_config\\(config\\)\n" line indentation)
+ (string-append indentation
+ "self.args.disable_check_update = True\n"
+ line)))
+ #t))))
(build-system python-build-system)
(propagated-inputs
`(("python-future" ,python-future)