summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 22:12:43 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 22:12:43 +0200
commitf5d4a138a7937f6a9ff4dd1cca693935322977ba (patch)
treef56f53d4284aba908e0f40d52a293fb8b2a1d6fa
parent86e278fc1ac9b261468081e89cbd6b695f98a71c (diff)
downloadpatches-f5d4a138a7937f6a9ff4dd1cca693935322977ba.tar
patches-f5d4a138a7937f6a9ff4dd1cca693935322977ba.tar.gz
gnu: Add libpagemaker.
* gnu/packages/libreoffice.scm (libpagemaker): New variable.
-rw-r--r--gnu/packages/libreoffice.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 9027a83864..98d646cddd 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -358,3 +358,32 @@ Aldus/Macromedia/Adobe FreeHand documents.")
(description "Libmspub is a library that parses the file format of
Microsoft Publisher documents of all versions.")
(license mpl2.0)))
+
+(define-public libpagemaker
+ (package
+ (name "libpagemaker")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "05zgj5ngg9z4b7dnrfs59nm0macm99lzyxv4mg53jcvp0mkgigfd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (arguments
+ ;; avoid triggering a build failure due to warnings
+ `(#:configure-flags '("--disable-werror")))
+ (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker")
+ (synopsis "Library for parsing the PageMaker format")
+ (description "Libpagemaker is a library that parses the file format of
+Aldus/Adobe PageMaker documents. Currently it only understands documents
+created by PageMaker version 6.x and 7.")
+ (license mpl2.0)))