summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-03-06 13:55:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-06 16:03:04 +0100
commite325c890763e89b9baeeeb78110b3a50c822b25a (patch)
tree4dce3474a0342091ec061ea8f2185f5c1bc7bcb3
parentfe58ab013be8b8232ed4de356b3d0cb8b1bbb847 (diff)
downloadpatches-e325c890763e89b9baeeeb78110b3a50c822b25a.tar
patches-e325c890763e89b9baeeeb78110b3a50c822b25a.tar.gz
gnu: r-rhdf5: Make build reproducible.
* gnu/packages/bioinformatics.scm (r-rhdf5)[arguments]: Remove timestamp and host system information from settings file.
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4756444d95..947f99aa71 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8760,6 +8760,16 @@ of gene-level counts.")
"src/hdf5source/hdf5small.tgz" "-C" "src/" )
(substitute* "src/hdf5/configure"
(("/bin/mv") "mv"))
+ ;; Remove timestamp and host system information to make
+ ;; the build reproducible.
+ (substitute* "src/hdf5/src/libhdf5.settings.in"
+ (("Configured on: @CONFIG_DATE@")
+ "Configured on: Guix")
+ (("Uname information:.*")
+ "Uname information: Linux\n")
+ ;; Remove unnecessary store reference.
+ (("C Compiler:.*")
+ "C Compiler: GCC\n"))
#t)))))
(propagated-inputs
`(("r-zlibbioc" ,r-zlibbioc)))