summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-03-16 22:18:15 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-16 22:58:37 +0100
commitd3fecbab82f17ef6736300cf2e18981d04ffc25f (patch)
tree901879ad95c28cb57bb720375f55ce1e15c98974
parent70526bdbe0221ed9077df31cb24374100685725b (diff)
downloadpatches-d3fecbab82f17ef6736300cf2e18981d04ffc25f.tar
patches-d3fecbab82f17ef6736300cf2e18981d04ffc25f.tar.gz
gnu: Add tla.
* gnu/packages/version-control.scm (tla): New variable.
-rw-r--r--gnu/packages/version-control.scm59
1 files changed, 58 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index bf97f89cd6..86b1d58654 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -2407,3 +2407,60 @@ interrupted, published, and collaborated on while in progress.")
videos, datasets, and graphics with text pointers inside Git, while storing the
file contents on a remote server.")
(license license:expat)))
+
+(define-public tla
+ (package
+ (name "gnu-arch")
+ (version "1.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ftp.gnu.org/old-gnu/gnu-arch/"
+ "tla-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01mfzj1i6p4s8191cgd5850hds1zls88hkf9rb6qx1vqjv585aj0"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; In tar 1.32, '--preserve' is ambiguous and leads to an
+ ;; error, so address that.
+ (substitute* "src/tla/libarch/archive.c"
+ (("\"--preserve\"")
+ "\"--preserve-permissions\""))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (chdir "src")
+
+ (mkdir "=build")
+ (chdir "=build")
+
+ ;; For libneon's 'configure' script.
+ ;; XXX: There's a bundled copy of neon.
+ (setenv "CONFIG_SHELL" (which "sh"))
+
+ (invoke "../configure" "--prefix" out
+ "--config-shell" (which "sh")
+ "--with-posix-shell" (which "sh")
+ "--with-cc" "gcc")))))
+
+
+ ;; There are build failures when building in parallel.
+ #:parallel-build? #f
+ #:parallel-tests? #f
+
+ #:test-target "test"))
+ (native-inputs
+ `(("which" ,which)))
+ (synopsis "Historical distributed version-control system")
+ (description
+ "GNU Arch, aka. @code{tla}, was one of the first free distributed
+version-control systems (DVCS). It saw its last release in 2006. This
+package is provided for users who need to recover @code{tla} repositories and
+for historians.")
+ (home-page "https://www.gnu.org/software/gnu-arch/")
+ (license license:gpl2))) ;version 2 only