summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-28 13:55:03 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-28 13:56:05 +0200
commitc6b3dc69bd4e6cd6f3457e3cfb671ca4e588344b (patch)
tree689b8290475304456638c1d10f74322d70addc0c
parentae32c58e2836f1c83609ebbb9eb9a632b63bae49 (diff)
downloadpatches-c6b3dc69bd4e6cd6f3457e3cfb671ca4e588344b.tar
patches-c6b3dc69bd4e6cd6f3457e3cfb671ca4e588344b.tar.gz
gnu: vlc: Drop -ffast-math from the compilation flags.
* gnu/packages/video.scm (vlc)[arguments]: Add "ac_cv_c_fast_math=no" to #:configure-flags.
-rw-r--r--gnu/packages/video.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d5880c45e2..06f7496b71 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -623,6 +623,12 @@ audio/video codec library.")
(arguments
`(#:configure-flags
`("--disable-a52" ; FIXME: reenable once available
+
+ ;; Gross workaround for <https://trac.videolan.org/vlc/ticket/16907>.
+ ;; In our case, this led to a test failure:
+ ;; test_libvlc_equalizer: libvlc/equalizer.c:122: test_equalizer: Assertion `isnan(libvlc_audio_equalizer_get_amp_at_index (equalizer, u_bands))' failed.
+ "ac_cv_c_fast_math=no"
+
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")) ;needed for the tests