summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-02 15:12:38 -0500
committerLeo Famulari <leo@famulari.name>2020-03-17 16:04:12 -0400
commit88841a3ead043f032d60e994bceeb20889d66262 (patch)
tree53c402ff05b76ff013c21c9d3edda8fccff9433c
parentcb78846c130c74c7c136c7b54584c94e2c672d1b (diff)
downloadpatches-88841a3ead043f032d60e994bceeb20889d66262.tar
patches-88841a3ead043f032d60e994bceeb20889d66262.tar.gz
gnu: Add go-github-com-willf-bitset.
* gnu/packages/golang.scm (go-github-com-willf-bitset): New variable.
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bf6209d8ea..b0dd5ffe12 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3394,3 +3394,26 @@ data serialization format.")
(description " A glob library that implements descending into other
directories. It is optimized for filewalking. ")
(license license:expat)))
+
+(define-public go-github-com-willf-bitset
+ (package
+ (name "go-github-com-willf-bitset")
+ (version "1.1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/willf/bitset")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wpaxg6va3qwd0hq0b8rpb1hswvzzbfm2h8sjmcsdpbkydjjx9zg"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/willf/bitset"))
+ (synopsis "Bitsets in Go")
+ (description "This package provides a Go implementation of bitsets, which
+are a mapping between non-negative integers and boolean values focused on
+efficient space usage.")
+ (home-page "https://github.com/willf/bitset")
+ (license license:bsd-3)))