summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 15:25:05 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 15:25:05 +0200
commit6f6eb857602393523071caf433a4f34c74b85531 (patch)
tree714488d9c8d657a1a0b9c4dd78605c16db09ce4d
parentc5d8e688dc79f8ea2094adf04d2274332cf5cb6c (diff)
downloadpatches-6f6eb857602393523071caf433a4f34c74b85531.tar
patches-6f6eb857602393523071caf433a4f34c74b85531.tar.gz
gnu: libtiff: Add "doc" output.
* gnu/packages/image.scm (libtiff)[outputs, arguments]: New fields.
-rw-r--r--gnu/packages/image.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 393d9cf5f2..76f73e03ca 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -114,6 +114,14 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
(sha256 (base32
"171hgy4mylwmvdm7gp6ffjva81m4j56v3fbqsbfl7avzxn1slpp2"))))
(build-system gnu-build-system)
+ (outputs '("out"
+ "doc")) ;1.3 MiB of HTML documentation
+ (arguments
+ ;; Instead of using --docdir, this package has its own --with-docdir.
+ `(#:configure-flags (list (string-append "--with-docdir="
+ (assoc-ref %outputs "doc")
+ "/share/doc/"
+ ,name "-" ,version))))
(inputs `(("zlib" ,zlib)
("libjpeg" ,libjpeg)))
(synopsis "Library for handling TIFF files")